Maven

maven-download-pluginでjava.io.StreamCorruptedException: invalid stream header: 00000000が出たときの対処法

とりあえず使ってたmaven-download-pluginが1.2.0と古かったので、1.4.0にバージョンアップしたら直った。 詳細な発生条件や原因はちゃんと調べられていないが、覚書としてメモしておく。 [前提条件] [問題の詳細] [解決策] [まとめ]

TLS1.2とMavenと時々Jenkinsの話とか

PCI DSSの基準によりTLS v1/v1.1が安全でない通信とされてから早1ヶ月以上が経った。 www.jcdsc.org 自分たちの運用するサイトもサクッとTLS1.2対応を済ませ、利用者の皆様には多少ご不便をおかけします、なんて思っていたら、自分が「ご不便」を被る羽目に…